Can't get Target Repository selector populated with Artifactory plugin

Hi,

was just trying the new features offered with the Artifactory plugin.
I've updated to TC 5.1.2, to Artifactory 2.2.3, downloaded plugin version 1.0.1.

Everything seem fine except that I can't get the Target Repository selector to be populated.
I'm 100% sure of the URL, username an pwd, tried many times.

What elese could get wrong?

BTW, what's the added value compare to a std maven deploy? - ie, if you use Maven2 build with deploy phase already.

best
nodje

2 comments

Hello,

Sometimes it gets populated quite slow. Unfortunately it currently indicates nor progress nor any failure of this process. If you're absolutely sure it's not just a slowdown, then it's probably worth contacting the plugin's developers at Jfrog - http://issues.jfrog.org/jira/

The main drawback of the standard mvn deploy process is that it's not transactional. If you deploy a multimodule project using mvn deploy there is a probability of deploying a non-consistent partial artifact set when one module fails. This could be quite confusing for artifact consumers especially when dealing with SNAPSHOTs.

0

I've set the Timeout to something quite long, tried on different browsers, no success up to now.

I'm not using multimodule project, I edit each every module as a separate project. Now that you mention it, I think I should give it a try

0

Please sign in to leave a comment.