Unable to install agent on Windows laptop

I've been running Teamcity for years with great success.  However, today, I'm trying to install a build agent on my Windows XP laptop so I can test some new build configurations, and it's failing.  This is the first time I've tried to install an agent on Windows (the others have all been on RHEL), so I'm not really used to it.  Essentially, the agent (from the Windows installer) came with almost no plugins, and went into upgrade mode shortly after I started it.  However, I keep getting a "FileNotFoundException (Access is denied)" in the middle of the upgrade install, at a different file each time.  I have 3 GB available on my HDD so that shouldn't be an issue (I hope).  The agent isn't running as a service; I tried to install it that way but I don't have access to do that (running either as System or as myself), so I just ran it with agent.bat.  I'm attaching upgrade.log; any help would be appreciated.



Attachment(s):
teamcity-agent.log.zip
launcher.log.zip
upgrade.log.zip
2 comments

Alas, that looks likely... thanks.  Unfortunately, disabling my antivirus is impossible and uninstalling Tortoise is going to be more trouble than it's worth.  I'll go another route (install the agent on a dev Linux box).  Thanks for your quick reply; I'm sorry I didn't see that first.

0

Please sign in to leave a comment.