Resolving artifact dependencies hangs

Hi,

My agent is on a Win7 64 bit virtual machine, I have two snapshots on it, snapshot1 and snapshot2, the only difference between them is that snapshot2 has UAC turned off.

So I run the same configuration on both these two snapshots, snapshot1 has no problem, but snapshot2 hangs at resolving artifact dependancies, please see the log below (the artifact is only about 300M)

[14:17:10]: Checking for changes
[14:17:13]: Checkout directory: C:\BuildAgent\work\38a12d5ab0f590ea
[14:17:13]: Updating sources: server side checkout... (1s)
[14:17:13]: [Updating sources: server side checkout...] Will perform clean checkout. Reason: Checkout directory is empty or doesn't exist
[14:17:13]: [Updating sources: server side checkout...] Transferring cached clean patch for VCS root: Class Suite
[14:17:13]: [Updating sources: server side checkout...] Building incremental patch over the cached patch
[14:17:14]: [Updating sources: server side checkout...] Repository sources transferred: 767.23Kb total
[14:17:14]: [Updating sources: server side checkout...] Removing C:\BuildAgent\work\38a12d5ab0f590ea
[14:17:14]: [Updating sources: server side checkout...] Updating C:\BuildAgent\work\38a12d5ab0f590ea
[14:17:14]: Resolving artifact dependencies (running for 44m:05s)
[15:01:19]: [Resolving artifact dependencies] Build cancelled



I tried the thread dump but it said no information there.


My TeamCity version is 5.1.2 (build 13430).



Can someone help?


Thanks,
Eileen
1 comment

It must have been some weird problem with that specific snapshot. I removed that snapshot and created another one exactly the same, then the problem was gone :^O

0

Please sign in to leave a comment.