Please....I just want to make Git submodules work properly

So I've posted on here regarding this before, we've been struggling with this for months.  We have multiple projects/build configurations residing on a single teamcity server/agent combo.  Each configuration shares a common submodule (at possibly different revisions).  The projects are on different repositories, and the configurations are on different branches.  Here's a simple overview:

Project 1 - Staging Branch -> Submodule
Project 1 - Production Branch -> Submodule
Project 2 - Staging Branch -> Submodule
Project 2 - Production Branch -> Submodule

Project 1 is all on the same repository, and project 2 is on a different repository, but they both point to the same submodule repository (but, as previously stated, to possibly different revisions).

All that said, team city has never been able to handle the submodules correctly.  We regularly have to delete the git checkout directories and even change the git checkout directory path just to get the projects to build.  We've tried every possible combination of settings, have applied every update, in the hopes that SOMETHING would work.  Most recently,  I've tried using checkout on agent and pointed to an msysgit binary on the agent.  It checks out the first time fine, however on subsequent builds it will just hang on "checking for changes" indefinetly.  Looking at the process explorer, I don't even see an instance of git.exe running (which i did see on the initial checkout).  I KNOW that our submodule/repository is set up properly, because I can manually run pull/submodule update from multiple machines, using mysysgit.

Just for reference, here is a previous post that I put on here: http://devnet.jetbrains.net/thread/287935

The issue that we're currently running into when using the built in git client (JGit I believe) is something like the following:

[18:26:39]: Patch  is broken, can be found in file:  C:\Builds\temp\cache\temp576460500321350425patch_837
[18:26:39]: RunBuildException  when running build stage UpdateSourcesFromServer: Failed to build patch  for build 203 {build id=837}, VCS root:  git@git.assembla.com:bizplan.git#Staging {id=10}, due to error: Patch  building failed:  jetbrains.buildServer.buildTriggers.vcs.git.submodules.SubmoduleFetchException:  Cannot fetch submodule. Repository URL:  'git@git.assembla.com:project.git', submodule path: 'MySubmodule'. org.eclipse.jgit.errors.TransportException: Short read of block. java.io.EOFException: Short read of block.


Thanks for any help in advance.


*Edit - I am using the modified plugin from this issue in order to enable submodule support on client side git checkouts : http://youtrack.jetbrains.net/issue/TW-12228
1 comment

Hello, Luke.

These errors look similar to errors in issue TW-12404 .
Please install the latest version of git plugin and let me know if they still occur.

0

Please sign in to leave a comment.