NCover integration

Hi all, I'm a bit confused about how to get the NCover coverage reports displaying within Team City. I have an MSBuild task that performs the NCover operation to generate the report, runs through MSTests to get the test results (which I was able to display within Team City using a ##teamcity directive), and then generates the  HTML report using NCover Explorer.

The report is being generated successfully to c:\sandbox\Reports\Report.html. In main-config.xml I added this:

<report-tab title="Full Coverage Report" basePath="reports" startPage="Report.html" />

Working directory is:

C:\sandbox\

I have a single Artifact paths entry:

reports => reports

I also tried changing the basePath in the report-tab element to be the full path to the report, but that didn't work either. Nothing in the UI.

Any ideas?

Thanks,

-tim

2 comments
Comment actions Permalink

Do you see generated reports in artifacts tab?

What is set to checkout directory for this build? All paths in atrifact paths are resolved agains checkout directory.

Please have a look at
http://confluence.jetbrains.net/display/TCD5/Build+Artifact

Staritng from 5.1 report tabs can be configured from web ui, please have a look at
http://confluence.jetbrains.net/display/TCD5/Including+Third-Party+Reports+in+the+Build+Results#IncludingThird-PartyReportsintheBuildResults-Tabs

0
Comment actions Permalink

Well, wasn't specifying a checkout dir. The extraction of code from SVN is handled elsewhere and is done as part of the msbuild script, not TeamCity. I was hoping that specifying a working directory would take the place of the checkout dir since none is specified.

I manually specified a checkout dir and that didn't help. I don't see any artifacts tab.

I'll see about updating to 5.1. We're on 5.0.2 right now.

:edit: I take that back, I was expecting them to appear on the configuration, not a specific build. Setting the checkout dir did get a "reports" directory to appear that I can expand, and I do see the new tab with the full report. Thanks!

0

Please sign in to leave a comment.