Mercurial clone fails (previously worked)

Our build configuration was working perfectly until a large changeset was pushed to the server recently (may be coincidental). Now all builds fail with the following RunBuildException:

[18:11:01]: Patch is broken, can be found in file: C:\BuildAgent\temp\cache\temp8951220889064411364patch_103
[18:11:01]: RunBuildException  when running build stage UpdateSourcesFromServer: Failed to build patch  for build 95 {build id=103}, VCS root: mercurial: c:\projects\xxx-dev\  {id=3}, due to error: 'hg clone -r 839dedebf4cf --pull -U  C:\Users\xxx\.BuildServer\system\caches\mercurial\hg_-6620884960889199840  rep' command failed. stderr: 586 files updated, 0 files merged, 0 files removed, 0 files  unresolved  stdout: requesting all changes adding changesets adding manifests adding file changes added 1323 changesets with 2365 changes to 782 files


In trying to resolve this issue, I've upgraded to TC 5.1.3 (build 13506) and Mercurial 1.6, but the problem persists.


If I run the command from the commandline:


hg clone -r 839dedebf4cf --pull -U  C:\Users\xxx\.BuildServer\system\caches\mercurial\hg_-6620884960889199840  rep

it completes successfully.

Any help would be greatly appreciated.

2 comments

Please attach teamcity-server.log and teamcity-vcs.log or send them to teamcity-feedback[at]jetbrains.com

0

Thanks very much Pavel - I've just sent the logs off.

0

Please sign in to leave a comment.