NCover 1.X and Mono on Ubuntu Server

Hi,

I have my nUnit build running fine under mono on my ubntu machine running TeamCity,

Now I have activated NCover 1.X and set the following:

Platform: 2.0
Version: x86
Path to NCover: /srv/tools/ncover/NCover.Console.exe
Path to NCoverExplorer: /srv/tools/ncover/NCoverExplorer.Console.exe

Now when my build runs I see the following error:

[14:54:57]: ApplicationName='/home/vps/TeamCity/buildAgent/plugins/dotnetPlugin/bin/JetBrains.TeamCity.PlatformProcessRunner.x86.exe', CommandLine='x86 v2.0 /srv/tools/ncover/NCover.Console.exe //a YetAnotherUtilsLib.Core //reg //x /home/vps/TeamCity/buildAgent/temp/buildTmp/tmp7decdd5a.tmp /usr/local/bin/mono /home/vps/TeamCity/buildAgent/plugins/dotnetPlugin/bin/JetBrains.TeamCity.PlatformProcessRunner.msil.exe MSIL "mono-2.0" /home/vps/TeamCity/buildAgent/plugins/dotnetPlugin/bin/JetBrains.BuildServer.NUnitLauncher.exe "@@" /home/vps/TeamCity/buildAgent/temp/buildTmp/tmp40080f4b.tmp', CurrentDirectory='/home/vps/TeamCity/buildAgent/work/6a18d45698b6018e'   at System.Diagnostics.Process.Start_noshell (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000] in <filename unknown>:0    at System.Diagnostics.Process.Start_common (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000] in <filename unknown>:0    at System.Diagnostics.Process.Start () [0x00000] in <filename unknown>:0    at (wrapper remoting-invoke-with-check) System.Diagnostics.Process:Start ()   at JetBrains.TeamCity.Utils.ProcessRunnerBase.Run (System.Diagnostics.ProcessStartInfo psi) [0x00000] in <filename unknown>:0    at JetBrains.TeamCity.Utils.Runtime.ProcessRun.Execute (IRunProcess proc) [0x00000] in <filename unknown>:0    at JetBrains.TeamCity.Utils.Runtime.ProcessRun.Run (System.String executable, PlatformVersion env, PlatformType platform, System.String[] args) [0x00000] in <filename unknown>:0    at JetBrains.TeamCity.Utils.Runtime.ProcessRun.RunWithCommandLine (PlatformVersion env, PlatformType platform, System.String assembly, System.String[] args) [0x00000] in <filename unknown>:0    at JetBrains.TeamCity.Utils.Runtime.RunInRuntime.ForkInRuntime (PlatformVersion version, PlatformType type, System.String executable, System.String[] args) [0x00000] in <filename unknown>:0    at JetBrains.TeamCity.NUnitCommon.PlugableRunFactory+RunProcessAsPlugable.Run () [0x00000] in <filename unknown>:0    at JetBrains.BuildServer.NAntLoggers.NUnitLauncher2.ExecuteTasks (ITestRunArguments arguments, JetBrains.TeamCity.NUnitCommon.IPlugableTestRunner[] plugRuns) [0x00000] in <filename unknown>:0    at JetBrains.BuildServer.NAntLoggers.NUnitLauncher2.Run2 (System.String[] args) [0x00000] in <filename unknown>:0    at JetBrains.BuildServer.NAntLoggers.NUnitLauncher2.Run (System.String[] args) [0x00000] in <filename unknown>:0
[14:54:57]: /home/vps/TeamCity/buildAgent/work/6a18d45698b6018e/default.build(29,5): NUnit launcher returns invalid exit code
[14:54:57]: NAnt output:
[14:54:57]: 2010-07-27 14:54:57,271 [-1285417152] ERROR JetBrains.BuildServer.NAntLoggers.NUnitLauncher2 - ApplicationName='/home/vps/TeamCity/buildAgent/plugins/dotnetPlugin/bin/JetBrains.TeamCity.PlatformProcessRunner.x86.exe', CommandLine='x86 v2.0 /srv/tools/ncover/NCover.Console.exe //a YetAnotherUtilsLib.Core //reg //x /home/vps/TeamCity/buildAgent/temp/buildTmp/tmp7decdd5a.tmp /usr/local/bin/mono /home/vps/TeamCity/buildAgent/plugins/dotnetPlugin/bin/JetBrains.TeamCity.PlatformProcessRunner.msil.exe MSIL "mono-2.0" /home/vps/TeamCity/buildAgent/plugins/dotnetPlugin/bin/JetBrains.BuildServer.NUnitLauncher.exe "@@" /home/vps/TeamCity/buildAgent/temp/buildTmp/tmp40080f4b.tmp', CurrentDirectory='/home/vps/TeamCity/buildAgent/work/6a18d45698b6018e'
[14:54:57]: System.ComponentModel.Win32Exception: ApplicationName='/home/vps/TeamCity/buildAgent/plugins/dotnetPlugin/bin/JetBrains.TeamCity.PlatformProcessRunner.x86.exe', CommandLine='x86 v2.0 /srv/tools/ncover/NCover.Console.exe //a YetAnotherUtilsLib.Core //reg //x /home/vps/TeamCity/buildAgent/temp/buildTmp/tmp7decdd5a.tmp /usr/local/bin/mono /home/vps/TeamCity/buildAgent/plugins/dotnetPlugin/bin/JetBrains.TeamCity.PlatformProcessRunner.msil.exe MSIL "mono-2.0" /home/vps/TeamCity/buildAgent/plugins/dotnetPlugin/bin/JetBrains.BuildServer.NUnitLauncher.exe "@@" /home/vps/TeamCity/buildAgent/temp/buildTmp/tmp40080f4b.tmp', CurrentDirectory='/home/vps/TeamCity/buildAgent/work/6a18d45698b6018e'
[14:54:57]: at System.Diagnostics.Process.Start_noshell (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000] in <filename unknown>:0
[14:54:57]: at System.Diagnostics.Process.Start_common (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000] in <filename unknown>:0
[14:54:57]: at System.Diagnostics.Process.Start () [0x00000] in <filename unknown>:0
[14:54:57]: at (wrapper remoting-invoke-with-check) System.Diagnostics.Process:Start ()
[14:54:57]: at JetBrains.TeamCity.Utils.ProcessRunnerBase.Run (System.Diagnostics.ProcessStartInfo psi) [0x00000] in <filename unknown>:0
[14:54:57]: at JetBrains.TeamCity.Utils.Runtime.ProcessRun.Execute (IRunProcess proc) [0x00000] in <filename unknown>:0
[14:54:57]: at JetBrains.TeamCity.Utils.Runtime.ProcessRun.Run (System.String executable, PlatformVersion env, PlatformType platform, System.String[] args) [0x00000] in <filename unknown>:0
[14:54:57]: at JetBrains.TeamCity.Utils.Runtime.ProcessRun.RunWithCommandLine (PlatformVersion env, PlatformType platform, System.String assembly, System.String[] args) [0x00000] in <filename unknown>:0
[14:54:57]: at JetBrains.TeamCity.Utils.Runtime.RunInRuntime.ForkInRuntime (PlatformVersion version, PlatformType type, System.String executable, System.String[] args) [0x00000] in <filename unknown>:0
[14:54:57]: at JetBrains.TeamCity.NUnitCommon.PlugableRunFactory+RunProcessAsPlugable.Run () [0x00000] in <filename unknown>:0
[14:54:57]: at JetBrains.BuildServer.NAntLoggers.NUnitLauncher2.ExecuteTasks (ITestRunArguments arguments, JetBrains.TeamCity.NUnitCommon.IPlugableTestRunner[] plugRuns) [0x00000] in <filename unknown>:0
[14:54:57]: at JetBrains.BuildServer.NAntLoggers.NUnitLauncher2.Run2 (System.String[] args) [0x00000] in <filename unknown>:0
[14:54:57]: at JetBrains.BuildServer.NAntLoggers.NUnitLauncher2.Run (System.String[] args) [0x00000] in <filename unknown>:0
[14:54:57]: 2010-07-27 14:54:57,425 [1209132864] ERROR JetBrains.BuildServer.NAntLoggers.NUnit2LoggingTask.NUnit2TaskEx - NUnit launcher returns invalid exit code
[14:54:57]: NUnit launcher returns invalid exit code:
[14:54:57]: NAnt.Core.BuildException: NUnit launcher returns invalid exit code
[14:54:57]: at JetBrains.BuildServer.NAntLoggers.NUnit2LoggingTask.NUnit2TaskEx.ExecuteTask () [0x00000] in <filename unknown>:0
[14:54:57]: BUILD FAILED
[14:54:57]: /home/vps/TeamCity/buildAgent/work/6a18d45698b6018e/default.build(29,5):
[14:54:57]: NUnit launcher returns invalid exit code
[14:54:57]: NUnit launcher returns invalid exit code
[14:54:57]: Total time: 2.7 seconds.
[14:54:57]: Publishing artifacts
[14:54:57]: [Publishing artifacts] Paths to publish: [teamcity-info.xml]
[14:54:57]: [Publishing artifacts] Publishing files
[14:54:57]: Build finished



Has anyone successfully got this working under mono before?


Cheers
Stefan
1 comment

Hello Stefan,

Thank you for reporting this, I have filed the issue as http://youtrack.jetbrains.net/issue/TW-12891 Please vote/watch it to be notified on resolution.

Kind regards,
Marina

0

Please sign in to leave a comment.