Setting mime-type for artifacts

One of our build artifacts is a ~200 mb solaris installer named *.bin.  When users click on this in the artifacts tab, Chrome and FF open this link in a new tab, like a text file.  Is there a way to configure the mime-type for the artifact link, or some other way to force a "Save As..." dialog to come up?

3 comments
Comment actions Permalink

Please take a look at the: TeamCity/webapps/ROOT/WEB-INF/web.xml file. You should add another mime-mapping entry:
  <mime-mapping>
    <extension>bin</extension>
    <mime-type>application/octet-stream</mime-type>
  </mime-mapping>

and restart your server.

0
Comment actions Permalink

Doesn't work.  And that mime setting is actually already set in TeamCity/conf/web.xml anyway.

0
Comment actions Permalink

Sorry for long the delay. The question is still actual with latest TeamCity release?

Kind regards,
Marina

0

Please sign in to leave a comment.