Include file problems

I'm trying to set up teamcity for a c++ project using a vs2005sln runner. Most goes just fine but some of the include files cannot be found. If I build the solution using VS2005 there's no problems so I know it's not an error in the source but a configuration problem. I've try with the default working directory and I've tryed using the the folder of the solution file as working directory cuz those where the only to things I could think of.

Can any one tell me what I might have missed in the configuration?



log dump:

...

  • z:\src\impl\yy.h(18, 0): error C1083: Cannot open include file: 'Impl/xxxh': No such file or directory
  • ..\..\Src\Impl\zz.cpp(11, 0): error C1083: Cannot open include file: 'yy.h': No such file or directory

......

4 comments
Comment actions Permalink

at closer expection it would seem the problem only is for files that either starts with a dictionary name like

#include "Dictionary/headerfile.h"

or files included witd angle brackets like

#include <configfilde.defined>

Any one got an idea of what Im missing?

0
Comment actions Permalink

Could you please check that these files exist on the agent in the checkout directory?

0
Comment actions Permalink

They do exist. Currently Im just running it from file system, no vcs and the above build I mention where I can build from inside VS is build using those exact files. If I change relativ paths to absolute path it works but that just no a solution unfortunately (way to many places we'd need to change).

0
Comment actions Permalink

Sorry for the long delay. The question is still relevant? If yes please leave a comment or create a separate thread.

Kind regards,
Marina
0

Please sign in to leave a comment.