CVS Ext Configuration with Password

I was trying to setup a VCS root for a CVS with Ext protocol and a password. I can make this work inside IntelliJ but not in TeamCity. Even when I start TeamCity in the foreground (catalina.sh run) and enter the password when asked for it does not stick or even connect.

In IntelliJ I have this CVSROOT:
:ext:@:]]>
and 'Use internal ssh implementation' and 'Force ssh2' selected as well as the password set.

Any ideas how this can be made to work?

-Andy

3 comments

Ext protocol requires path to rsh command to be specified. If your VCS repository allows SSH access I would suggest to choose ssh protocol instead.

--
Pavel Sher

0

I set the path and tried both 'rsh' as well as 'ssh' but neither worked. Unfortunately the ssh protocol does not work (tried it within TeamCity but also on the command line as well as in IntelliJ).

A strange problem is that even when I enter the password on the command line TeamCity fails to connect to the CVS repository.

-Andy

0

Sorry for the long delay. The question is still relevant? If yes please leave a comment or create a separate thread.

Kind regards,
Marina
0

Please sign in to leave a comment.