Build Agent Disconnected

I moved my TeamCity install from the root level of the tomcat install into a directory called 'teamcity' (renamed ROOT to teamcity as per the instructions to install TeamCity and YouTrace on the same server), and now my build agent shows up as disconnected.  The services panel (on Windows Server 2003) shows TeamCity Build Agent Service and TeamCity Web Server as both started.  How can I get my build agent back?

I don't know whether it matters, but since I've seen a couple of posts talking about build agents trying to update themselves, the machine these are installed on is on an internal network and is not able to reach the internet.  But the build agent worked fine after the initial install.  It just didn't work after I renamed the ROOT directory (which required me to temporarily stop the TeamCity Web Server service).  I have tried rebooting the machine with no improvement.

1 comment

I think I solved my own problem.  I edited the buildAgent.properties file in TEAMCITY_ROOT\buildAgent\conf and updated the serverUrl property to point to the new location.  Now everything is running fine.

0

Please sign in to leave a comment.