Eluru 6.0 EAP hung process

I have been encountering issues recently with zombie processes left behind from TeamCity.  I am seeing this behavior on my Windows clients ( Windows Server 2008 R2 x64).
Most of our official build machines on Windows Server 2008, so I haven't run many builds through TC on other Windows Platforms.

What I am seeing is that in certain cases TC leaves zombie like processes around that can't be killed through the task manager or process explorer.  When I look at the parent, it says that the parent process is not available.  I can see the command line on the processes and it is definitely part of a TC run.
For the most part I have seen link and midl exes left running from VS 2008 and robocopy.  We also use IncrediBuild and there are times when that process hangs indefintely and again, I can't kill the process.

I have seen this on at least 4 different machines now.  The only way to kill the process is to reboot the machine.  I have tried stopping the TC agent, killing all instances of Java, and even killing explorer.exe.
I have tried manually  reinstalling the agent and UAC is completely disabled and all TC agents run under admin accounts.
We were running 5.1 and have upgraded to the latest 6.0 EAP.

Is there any way to diagnose this issue or have others experienced the same?

thanks,
nsn

1 comment

Hello,

Could you please list build runner settings? Did you try to run the build without TeamCity?

Thanks in advance,
Marina

0

Please sign in to leave a comment.