Unable to find path to MSBuild

Hi,

I'm running the EAP version and trying to build a VS2010 solution however I get the following error message and was wondering if anyone could suggest how I fix it.

[10:53:27]: BuildStageExecutionException when running build stage ForEachBuildRunnerStage: Unable to find path to MSBuild
[10:53:27]: Build finished



Thanks

Tim

4 comments

Please add more details: build agent, .NET frameworks, build agent debug logs, runner configuration screenshot. Thanks!

0
It's running on a Windows Server 2008 x64 (both TC and the Agent are the same machine in this instance). Building for ASP.Net 4.0.



Here's the complete log through the TC interface:


[10:53:23]: Checking for changes
[10:53:25]: Clearing temporary directory: D:\TeamCity\BuildAgent\Temp\buildTmp
[10:53:25]: Checkout directory: D:\TeamCity\BuildAgent\Work\4b85de2c496b90af
[10:53:25]: Updating sources: server side checkout... (1s)
[10:53:25]: [Updating sources: server side checkout...] Building incremental patch for VCS root: Crisis Cover SVN
[10:53:27]: [Updating sources: server side checkout...] Repository sources transferred
[10:53:27]: BuildStageExecutionException when running build stage ForEachBuildRunnerStage: Unable to find path to MSBuild
[10:53:27]: Build finished


Not sure where to get the Build Agent's log files from or the Runners screenshot.
0

What is TeamCity version?
Please attach screenshot if a build settings section of a build configuration settings.
Check this http://confluence.jetbrains.net/display/TCD5/Reporting+Issues for instructions on how to post logs

0

Thanks Eugene, I've found the cause of my error -the server didn't have the Microsoft SDK installed.

Installing it has resolved the issue.

Tim

0

Please sign in to leave a comment.