creating artifacts

hi,
i'm having trouble creating artifacts...teamcity 5.1
i've created an artifact path, my MSbuild script is deploying the build to here: \\[server name]\wwwroot\[application name]

so under administration > project > project configuration > artifact path:
\\[server name]\wwwroot\[application name]\* => source

this isnt working.  any suggestions on where im going wrong?

2 comments

Hi nologo,

Does  "\\[server name]\wwwroot\[application name]" exist in the Team City server's file system? By the way, I'm not sure if Team City understands the "\\[hostname]" syntax. All artifact paths are relative to the checkout directory, so you don't need to provide an absolute path. In my case, my checkout directory contains all my project folders, each with their Debug and Release folders, and I put all my artifacts in .zip files, so my artifact paths are like this:

For managed projects:

[ManagedProjectName]/bin/Release/[ManagedAssembly].dll => ManagedAssemblies.zip

For native projects (all native binaries go to the Release directory inside the checkout directory):

Release/[NativeAssembly].dll => NativeAssemblies.zip

A word of advice, don't take it bad: If you just say "it's not working" and don't say which error message you're getting, chances are you won't get answers

0

thanks for the reply.  no worries..i know it how i had it configured..because no error was generated.
i was just missing setting the artifact path on my initial project..thus why i was unable to collect artifacts.

thanks

0

Please sign in to leave a comment.