Problems with Multi-line variables

I posted a an issue on stack overflow, trying to figure out how to get IDEA code coverage to work with multi-line variables. Long story short I'm trying to use IDEA code coverage with java builds and I can't seem to get multi line variables to work for my inclusion and exclusion rules. When I don't use variables everything works but this means I can't use the flexibility of the templates really. Am I missing something? Is this just a bug?

http://stackoverflow.com/questions/4114685/team-city-issues-with-using-multi-line-variables-impacting-idea-code-coverage

11 comments

Can't reproduce it so far, maybe you could provide a build log?

0

Can I email you the logs directly?


0

You can use teamcity-feedback[at]jetbrains.com email address.

0

Yes I did, but unfortunately I have no idea currently, what went wrong. Are there any errors in the teamcity-agent.log file on the agent where build with variables executed?

0

There's nothing really of note in teamcity-agent.log or error.log unfortunately. I can reproduce the issue everytime, is there some piece of info I can get you or a setting I can change to get you more info?

0

Could you please send us .BuildServer/<project name>/project-config.xml file for the case when variables are used?

0

I sent the logs to the email mentioned before.


0

Jeremy, please check that you have debug info enabled when your classes are compiled. Without debug info, coverage can't be gathered.

0

Please sign in to leave a comment.