Setting up dotCover with TeamCity 6

Hello all,

I have just setup TeamCity 6 and I am trying to integrate dotCover into my build.  The NUnit execution happens inside the MSBuild script.  I think I read on the site that this is ok, and that a seperate NUnit step does not need to be added.

I set the Code Coverage tool to dotCover and specified this Assembly Filter:
+:assembly=*;type=*;method=***

After a successful build, I am not seeing my dotCover stats anywhere.

Any suggestions?


Thanks!

-Tom

3 comments

This still does not seem to be working for me.  It seems the coverage session never starts.

I'll mention again that I only have an MSBuild step, and within my MSBuild script there are <NUnit> directives.  The team city docs suggest that this should be ok, but I just want to throw that out there.

0

Please attach build log.

If you use MSBuild runner with enabled dotCover .NET code coverage, please try removing any dotCover filters. Does it work? What filters do want to set for code coverage? Do you see coverage statistics on the build results page?

0

Please sign in to leave a comment.