TeamCity builds hang on version 6

I have recently upgraded teamcity 5.1.1 to version 6 and am now facing  problems with the upgrade. All of my builds seem to hang once it has  finished building, it logs a message "Process exited with code 0" at the  end of the build. This issue has been raised before listed on youtrack when we where using  5.1.1 (ticket TW-12798) and seems to have reappeared again.

1) I have tried running some of the commands that where mentioned in TW-12798 but have run into a problem when using your tools:  JetBrains.TeamCity.Injector.exe <pid_of_java_process> command I  get the below error:
Error -10. Failed to attach to process: failed to start thread.
2)  Then I tried using the jstack but it returned with Not enough space to  complete this task (although there is enough disk and ram available).
3)  When trying to find which process is hanging by using the teamcity UI  "View Thread Dump" it says "TeamCity was unable to locate any processes  of this build."

I have attached the plugin that was issued in TW-12798 but still experience the same problem. I have attached as much information as I can.

Please advise.



Attachment(s):
threadDump-2011-01-04_13.58.44.txt.zip
teamcity-server.log.zip
teamcity-build.log.zip
teamcity-agent.log.zip
1 comment
Comment actions Permalink

Hi, Arun

Is this post related to your later question - http://devnet.jetbrains.net/message/5282939#5282939 ?

0

Please sign in to leave a comment.