Using an alternative "landing page" for teamcity

Our teamcity frontpage has 20 enormous projects.  Loading the page takes over a minute.  We suspect that our 40 developers hitting that page
is the reason why teamcity is often painfully slow for us.

Is there a way to not have this homescreen with all projects on it?  (Other than the "Hide project" client side settings that each developer would have
to do manually)

Thanks, Lucas

7 comments
Comment actions Permalink

Hi Lucas,

Sorry for the delay.

Have you considered using user permissions for limiting users' view?
Also if some projects are inactive you can archive them.

0
Comment actions Permalink

Same issue here Sergey, and limiting permissions is not an option. The landing page is extremely slow even on faster browsers (i.e. Chrome)

0
Comment actions Permalink

TeamCity currently behaves like this: if a user did not configure visible projects and a number of configurations to show is less than 200, then complete overview page is shown. Otherwise, user will asked to configure visible projects first.
The limit of 200 build configurations is quite large, I think we need to reduce it. The good news the limit is configurable. You can add internal property:
teamcity.overviewPage.buildTypes.limit=<number of configurations>

to .BuildServer/config/internal.properties file. You need to create this file if it does not exist. After that the server must be restarted.

0
Comment actions Permalink

Pavel, the landing page is simply too heavy, are there plans to speed it up?

0
Comment actions Permalink

Well, we are looking for alternative approaches, but I am not sure we will be able to address this problem in the near future. Probably in version 7.0.

0
Comment actions Permalink

Just being able to configure _serverside_ to have an empty landingpage would solve 99% of all real world problems.

This is very much hurting our team, I hope you'll consider adding such an option in the near future

Bye, Lucas

0
Comment actions Permalink

I think now you can achieve the same behavior if you specify teamcity.overviewPage.buildTypes.limit=0 in the internal.properties file.

0

Please sign in to leave a comment.