HSQLDB to 2008R2 SQLEXPRESS

I am migrating a test implementation to SQL Server from HSQLDB on a Windows 2008 R2 Server with a 2008 R2 version of SQL Express and moving the default .BuildServer

directory from c:\users\<username>\.BuildServer to e:\TEAMCITY\.BuildServer for space reasons.

I used XCOPY to copy c:\users\<username>\.BuildServer to e:\teamcity\.BuildServer

TEAMCITY_APP_DIR is set to e:\teamcity\webapps\ROOT

TEAMCITY_DATA_DIR is set to c:\teamcity\.BuildServer

ran tomcat6w.exe //ES//TeamCity

and modified Java entry to:

-Xmx750m
-XX:MaxPermSize=200m
-Dcatalina.home=E:\TeamCity
-Dcatalina.base=E:\TeamCity
-Djava.endorsed.dirs=E:\TeamCity\common\endorsed
-Djava.io.tmpdir=E:\TeamCity\temp
-Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
-Djava.util.logging.config.file=E:\TeamCity\conf\logging.properties
-Dteamcity_logs=E:\TeamCity\logs\
-Dlog4j.configuration=file:E:\TeamCity\conf\teamcity-server-log4j.xml
-Dteamcity.data.path=E\TeamCity\.BuildServer

A new empty database called TEAMCITY01 was created in SQLEXPRESS with SA as DBO

A copy of database.properties was made in c:\tempdata directory with the following information:

connectionUrl=jdbc:jtds:sqlserver://pinv-devci:1433/TEAMCITY01
connectionProperties.user=sa
connectionProperties.password=<password>

migrateDB.cmd -Tc:\tempdata\database.properties

was run and successfully created database tables in TEAMCITY01

But... when rebooting the server I am still connecting to HSQLDB database.

Interestingly enough - when starting TEAMCITY with "runall start" command from e:\teamcity\bin directory I am connecting to the SQL Server DB TEAMCITY01 - but none of the data migrated from HSQLDB.

Where did I go wrong?

3 comments
Comment actions Permalink

One odd issue:

When running Teamcity as a service, the server configuration shows the Data Directory as

C:\Windows\system32\E\TeamCity\.BuildServer

and the artifacts directory as:

C:\Windows\System32\E\TeamCity\.BuildServer\system\artifacts

the Cache directory is set as:

E/TeamCity/.BuildServer/system/caches

I cannot find any references to c:\windows\system32\E\TeamCity\.BuildServer anywhere in the registry or path

When running TeamCity from "runall start" directory references are set to e:\TeamCity\.BuildServer as expected

0
Comment actions Permalink
-Dteamcity.data.path=E\TeamCity\.BuildServer


I'm going to guess it's because you're missing the colon:



-Dteamcity.data.path=E:\TeamCity\.BuildServer

0
Comment actions Permalink

That did the trick, TeamCity now boots into SQLServer rather than HSQLDB.

Not sure how I missed that. Probably because I am looking working on the configs after midnight.

The data did not migrate though.

Probably due to the missing ":".

I will revert and try the migration again.

Thank you for the second look.

0

Please sign in to leave a comment.