VCS (SVN) Builds not triggering

Using TeamCity version 6.0.2 (build 15857).

I have a project with two build configurations, both set to trigger on changes in an svn repository, but only the first build configuration responds to changes in source control.

The first build config responds to svn changes as expected: changes show up as "pending," and shortly thereafter the build starts. This works fine.

The second project "notices" the changes - ie, they show up as Pending on the Projects screen in TeamCity - but the build never actually starts.

These projects are configured *identically*, except for slight changes in the checkout rules and build runner. They share the same VCS root, and every setting on every screen is identical except for the checkout rules and a parameter for MSBuild:

Checkout rules for Project 1 (working)

-:.
+:Packages
+:libraries
+:www.keil.com/trunk/net.www.keil.com

Checkout rules for Project 2 (not working)

-:.
+:Packages
+:libraries
+:www.keil.com/trunk/asp.www.keil.com



Build runner for Project 1 (working)
teamcity.net.build.config.png
Build runner for Project 2 (NOT working)
teamcity.asp.build.config.png
The only difference is one of the command line parameters.
Project 1 (working)
/p:Configuration=Dev;useWPP_CopyWebApplication=true;OutputPath=c:\build;WebProjectOutputDir=s:\iisshares\http\net.www.keil.com;PipelineDependsOnBuild=false

Project 2 (NOT working)
/p:Configuration=Dev;useWPP_CopyWebApplication=true;OutputPath=c:\build;WebProjectOutputDir=s:\iisshares\http\asp.www.keil.com;PipelineDependsOnBuild=false

I've been through every screen in the both project settings side-by-side, and the only differences I see are the MSBuild parameters and the checkout rules.

HELP.

6 comments
Comment actions Permalink

Just for the hell of it, here are screenshots of the VCS config screens and checkout rules:

Working:

teamcity-build-config-net.png
teamcity-vcs-net.png

Not Working:

teamcity-build-config-asp.png

teamcity-vcs-asp.png


0
Comment actions Permalink

I am not sure you need to exclude the root path when you have include rules. So you might try removing the "-:." parts.
Daniel

0
Comment actions Permalink

Perhaps, but I don't see how that could cause this issue; I have the same "-:." rule for the project that works correctly. ??

0
Comment actions Permalink

David,

  Do you have any build triggering rules specified for your configurations?

  Regards,
  KIR

0
Comment actions Permalink

Hi Kirrill,

Yes, I have VCS triggers. Both projects have identically-configured VCS triggers using the default config:

vcs_trigger.png

0
Comment actions Permalink

Hello David,

  Could you please post here the changes which didn't trigger the build? How do they look like in TeamCity UI?

  Could you please also send us logs from TeamCity/logs/teamcity-vcs.log ?

  Thanks!
  KIR

0

Please sign in to leave a comment.