Build Agent consuming 100% CPU usage

Hey folks,

I've recently done an upgrade from version 5 to version 6 and am having some issues with my build agents.

I have an Ant build which is configured to run every hour, the build does a few things including a database rebuild, copying/extracting/zipping some files then starting up a JBoss server to execute a bunch of unit tests.  In TC5 the build worked fine, usually taking around 20-30 minutes to complete.  However when I try to run the same build under TC6, when it comes to the copying/extracting/zipping task, the CPU usage of the agent shoots up to 100% and a task that usually takes between 1-2 minutes takes up to around 30 minutes to complete.  I've tried breaking up the build into multiple ant builds for the seperate tasks and it makes a marked difference; the  copying/extracting/zipping task was reduced to 1-2 minutes however when it comes to starting JBoss I have the same issue with the agent.  Is there any changes to the agent in TC6 which could be causing this?  I have since reverted back to TC5 but would quite like to get TC6 working correctly to gain access to some of the new features.

Thansk,

Nick

2 comments
Comment actions Permalink

Nick,

This can be caused by TW-15335. You can try with the patch attached int he issue. Also, we plan to release 6.0.3 with the fix included in about a week.

If the plugin form the issue does not help, can you please check that it is the agent process that is loading the CPU?

0
Comment actions Permalink

Excellent thanks, that seems to have done the trick!

0

Please sign in to leave a comment.