Runner Type of "Command-Line" not creating installer using Altiris Wise

Hi there!

I am new to team city and would like to request for your help:
- We are using old technology (visual foxpro, wisescript installation package to create the installer)
- We are moving to new technology and would like start doing continuous integration using TeamCity
However, I keep getting stuck with the actual build of the installer.

At the moment, we are only using the command line as runner type.  I have already tried using either run as "custom script" or "command line with parameters."

When running as a simple batch file in the command line, it works and produces "installer.exe".  However in TeamCity, it always fails either as not building "installer.exe" or "process exited with code 33102."

I am not sure what to do next.  The following is the line that I need to execute (where the parameters /c -> compile & /s -> silent mode):
"C:\Program Files\Altiris\Wise Installation Studio\WiseScript Package Editor\Wise32.exe" /c /s ""c:\source\xxxxxx\module\install\xxxxxxxxxxxxxxxx\countrycode\deploy_windows\installer.wse"

Please note that I have already changed in "Control Panel -> Administration -> Services -> TeamCity Build Agent" to use the build server logon user and not "Local User" because if I don't do this, TeamCity does not build the application files from visual foxpro that needs to be picked up by the wise script.

Could you please help me and point me what to do / try out next?

Thanks very much in advance!

1 comment
Comment actions Permalink

Found my problem... after reading a "few" threads from the discussion forum... :D


If I run Wise32.exe with /c (compile) and /s (silent mode), results are as follows:

  • Installer.ws4 created then deleted once it reaches 6KB
  • TeamCity fails run, displays message "Process exited with code 33102" (I found no description of what this exit code means, web search doesn't return much valid results except for my own question here, lol)



From one of the threads, they say to "remove the silent" mode... so I ran Wise32.exe with /c only...

  • Installer.ws4 was created and is not being deleted even after it reaches 6KB
  • TeamCity does not fail the run... and continues to run but Installer.ws4 file size is not increasing...



So I was able to copy Installer.ws4 file and opened it in notepad -- I found out what was the last application file that it was able to read / last step before TeamCity started "hanging"...

I checked the Installer.wse script and searched for this application file and saw the next step --> VOILA! It was trying to access a file in the network.


I commented this line that accesses a file in the network and Installer.exe is being created beautifully.


The problem was just different login details from our build server to the network drives.

0

Please sign in to leave a comment.