External viewer icon not showing for fisheye

Hi,

I have configured external viewer for fisheye by using change-viewers.properties and added links for fisheye but i dont' have any icons for external viewer in the changes tab in the teamcity or anywhere else. I see only icons to load in local IDE. There are no errors in team city logs and i can see inly that change-viewers.properties is loaded. I have professional version of teamcity 6.5

Any ideas what to look for why is not working? I have checked VCS rootId should be correct the same as in url when i am editing VCS root.

In change-viewers.properties i have

1.changeSetUrl=http://crucible/changelog/path_hidden/_trunk/main.br?cs=${changeSetDisplayRevision}
1.fileDiffUrl=http://crucible/path_hidden/_trunk/main.br/${relativePath}?r1=${fileRevisionBefore}&r2=${f
1.newFileUrl=http://crucible/browse/path_hidden/_trunk/main.br/${relativePath}?&r=${fileRevisionAfter}

In logs i can see it was loaded:

[2011-06-07 05:53:03,897]   INFO - r.plugins.ChangeViewersOptions - Loading class jetbrains.buildServer.plugins.ChangeViewersExtension options from {1.fileDif
fUrl= etc...

Thank you

Pavel

1 comment
Comment actions Permalink

Hi Pavel,

Please try to set * instead of "1" in the properties file:
*.changeSetUrl=...

If that doesn't help, I'm going to build a special version of the plugin with lots of debug logging. So far no clues why it didn't work.


---
Maxim

0

Please sign in to leave a comment.