Getting wrong compilation failed result

Hi to everyone,

I've added an external application to the building process of a MSBuild project (through an Exec task), and it is making TeamCity believe the compilation failed because it prints "Error ..." at the start of a line. However, it is not an error, and even if it actually would be one, the Exec task is set to ignore the exit code of the command, which is what the external app uses to notify of errors.

What can I do?

Best regards.

2 comments
Comment actions Permalink

No workaround for this? I tried to start an investigation and mark the problem as solved just in case it could be related to solving my issue, but doesn't seem to be the case.

0
Comment actions Permalink

TeamCity starts MSBuild with a listener implementations that create messages from MSBuild events.

If you specified <SomeTaskOrExec ... ContinueOnError="true" /> to run your Excel task, MSBuild will not break the build, but it does not filter all error messages that were logged. This means, you may recieve a error messages in the build output or TeamCity build log.

TeamCity treats all errors in *.csproj/*.vbproj/*.vc?proj project files as compilation errors.

The workaround could be to start a commandline process with error output redirect, i.e. cmd /c <all commandline to run> 2>&1

0

Please sign in to leave a comment.