Profile hasRegion is not defined

I'm attempting to use TeamCity on EC2 and set up Cloud Agents. When setting up a new cloud profile I'm running into some problems. I enter my Access Key ID and my Secret access key from Amazon Web Services and then press the "Check Connection/Fetch Parameter Values" button I get the following alert dialog:

"hasRegion is not defined"


At this point I cannot continue and I cannot create the profile.

I'm using Google Chrome. When I get this message.

If I use Firefox I get this error message: reference to undefined property "hasRegion", in a dialog alert box.

I tried generating a new access key and tried using that, however I get the same error.  I have checked the server logs, and I do not see any errors anywhere. What might be the issue and how do I resolve it?

Thanks,

Donn

3 comments
Comment actions Permalink

Please note, I was running 6.5.2

I downgraded to 6.5.1 and it worked fine. The problem is in 6.5.2 only.

0
Comment actions Permalink

Thankyou for reporting the the problem. I created an issue at
http://youtrack.jetbrains.net/issue/TW-17657

Please take alook on it (and watch it changes)

0
Comment actions Permalink

Please take a look to the issue page I wrote in the previous post.
I'll described a hot fix for you.
Let me know if you need a patch

0

Please sign in to leave a comment.