LDAP issues

Hello,

I am trying to get LDAP setup on Teamcity 6.5.

I am following the guide here: http://confluence.jetbrains.net/display/TCD65/LDAP+Integration

Now the guide says to edit the ldap-config.properties file, but I dont see one. All I see is ldap-config.properties.dist (which gets overridden on server startup)

I tried creating the file in the same directory as the .dist file but that does not seem to have worked.

Any help would be great
:)

3 comments
Comment actions Permalink

Fixed it.

the java.naming.security.principal needed to be in the format xxxxxx@yyyyy.com and not yyyyyyy\xxxxxxx

Wish the documentation had that written in there.:(

0
Comment actions Permalink

Graham,
I'm trying to also get LDAP authentication to work in TC 6.5 (6.5.1 actually), and my LDAP admin had instructed me to configure TC to do an "anonymous" bind, which I think means to set java.naming.security.authentication=none, but this prevents TC from actually performing the bind operation correctly (i.e. when I enter a bad password, it still passes the bind step for some reason).    I guess my question to you is...  what did you end up setting java.naming.security.principal to in order to get LDAP auth working?   Is it some administrative id that needs to be assigned by the LDAP server's administrator???

Thanks,
Phil

0
Comment actions Permalink

The java.naming.security.principal i used what in the format username@domain

I.E. if my domain name: dev.companyname.com the full user name would be

username@dev.companyname.com

hope this helps?

0

Please sign in to leave a comment.