SSH connection problem when changing connections (hopefully simple)

Test connection failed in APP :: APP Build Project. Connection test failed: org.eclipse.jgit.errors.NoRemoteRepositoryException: ssh://youtrack@machine/gitroot/main.git: The server's host key is not cached in the registry. You

have no guarantee that the server is the computer you

think it is.

The server's rsa2 key fingerprint is:

ssh-rsa 2048 38:76:57:18:ec:13:6f:33:cb:00:41:3e:70:3c:f0:00

Connection abandoned.

I searched High and low for somewhere/way to clear the server fingerprint cache and could not find anything.  Hopefully someone can help.

2 comments
Comment actions Permalink

So I figured this out on my own.  The error occured when I changed boxes I was running on and changed from installing the windows service from running as the user I was logged on with to the system account.  The work around was just to change the service to run as the user I was logged on with.  I am using git with the master hosted on a linux machine.   Is their a permissions settings I could use to make this work under the system account?

0
Comment actions Permalink

Hi David,

I think the error you get means that you don't have your server's fingerprint in the known_hosts database of the system user. You can either select option 'Ignore Known Hosts Database' in the Vcs root settings or try to login through ssh to your server from the system account, and say 'yes', when ssh will ask you if you want to add server fingerprint into the known host database. Please let me know if it helps.

0

Please sign in to leave a comment.