Custom build not picking currect parametrized svn url

I am using Teamcity 6.5.1 on Unix machine.
I am facing issue in build config not picking up right parameterised svn url. Please see below detail of the issue.

Issue:
The issue comes when  we are using a parametrized svn url in our build configuration. At the time of  our custom build, in the properties tab we are giving a svn url. On running  the custom build, temacity does not check out code from the svn url given at the  custom build time, rather it picks up the default svn url given in the build  parameters or a url mention in the vcs roots. Also sometimes if it does pick up  the correct url, on updating our code and doing our custom build again, teamcity  does not pick up the latest code revision from svn.


Below are the exact  steps in replicating this issue:
1. Create a new branch out of trunk (https://svn.dts.fm.rbsgrp.net/sigma/branches/Georgios_Test_Branch_1.0 )
2. Added a file 0551_Test_change.sql, will  help me verifying whether teamcity is copying the correct files or  not.
3. Run a  build(#3.30.6169.88, 07 Sep 11 17:03)  with this configuration:
svn3.bmp

4. This build did checkout the new file
5. Added another  file 0552_Test_change.sql. The latest SVN  revision then became 6170.
6. Run another custom build with the same  configuration (#3.30.6169.89, 07 Sep 11 18:05).  This build did not pick up the change.
7.  Run another custom build with the same  connfiguration (#3.30.6169.90, 07 Sep 11 18:16). This build did not pick up the  change.


Below are some of the  screenshots of our  settings:
svn.bmp


svn2.bmp
2 comments
Comment actions Permalink

Hi

We fixed related issues in later builds. is it still reproduced in 6.5.4?

0
Comment actions Permalink

We have tried the custom build on 6.5.3 version as well , the issue is still there. We have not tried it yet on 6.5.4 We will be migrating to Teamcity release 7 once that is available . We plan to test the issue next on release 7 .

0

Please sign in to leave a comment.