Windows tray notifier login problem

Hi all,

I'm having some problems configuring Teamcity Windows tray notifier v6.5.4.

I'm currently setting it up on a business LAN network with Teamcity installed on a server and several clients with tray notifier installed connecting to that server.

However it seems that on any given client I'm unable to login to Teamcity via Internet Explorer 9 and Windows 7 and that goes both for trying to login directly to Teamcity using IE9 or trying to connect to TeamCity through the tray notifier (and thus also IE9).

All I get is the error message that I need to enable support for cookies in IE9, which is already done as _all_ IE9 security settings are either turned off completely or turned down to the lowest setting.

I have no problem connecting the two directly on the server.

Do any of you talented people know if this is either a tray notifier, IE9 or network security problem? I'm guessing I can't be the first one experiencing this problem. Any ideas?


Regards,
Anders

6 comments
Comment actions Permalink

Hi Anders

In Internet Explorer cookie settings are set separatelly on Privacy tab, not on Security tab.
Could you recheck them please.

0
Comment actions Permalink

I can confirm that in IE9 settings under the Privacy tab -> Settings is set to "Accept all cookies".  Under the Security tab the Security Level is set to "medium" for all zones, both Trusted Sites, Internet and Local Intranet.

0
Comment actions Permalink

Worked out the problem.

It seems that TeamCity Windows Tray Notifier fails if you enter a domain name in the TeamCity Server Selection box (like "http://my_domainserver"). Instead it requires that you write the specific IP address of the server to connect even though it amounts to the same thing.

0
Comment actions Permalink

what is full string you enter?
do you specify http:// prefix, or just server name?

0
Comment actions Permalink

To connect to the server I've used full HTTP URL path, ie. initially I entered a connection string that was like this : "http://MYDOMAIN". That didn't work and tray notifier kept trying to connect to the server. Then I changed it to : "http://190.168.1.1" and then it worked like a charm. Didn't specify port (80) since I assumed that that would be inferred by specifying the http protocol and also the server was setup for using port 80.

Hope that clarifies things :)

0
Comment actions Permalink

The IP address mentioned above is of course only an example, I didn't try to get the tray notifier to connect to my router :)

0

Please sign in to leave a comment.