Test fail but TeamCity is green

teamcity.jpg
And the corresponding log :

[testProtectedLinkedList] #failure testProtectedLinkedList /home/teamcity/svn_checkout/Galil/Common/BasicInfra/FoundationClasses/tests/FoundationClassesCuteTest.cpp:178 Unexpected log message was received
[17:32:01]: [testProtectedLinkedList] Unexpected log message was received
[17:32:01]: [testProtectedLinkedList] /home/teamcity/svn_checkout/Galil/Common/BasicInfra/FoundationClasses/tests/FoundationClassesCuteTest.cpp:178
[17:32:01]: [testProtectedLinkedList] #ending FoundationClasses Tests
[17:32:01]: 01.049055 (DBG) Unregistering package 'Foundation Classes Test package'           <==   /home/teamcity/svn_checkout/Galil/Common/OSAL/src/PackageManager.cpp:76
[17:32:01]: (DBG) Destroying Linux mutex of package 'OSAL Package'           <==   /home/teamcity/svn_checkout/Galil/Common/OSAL/os_specific/linux_x86/OSALMutexLinux.cpp:28
[17:32:01]: (DBG) Unregistering package 'OSAL Package'           <==   /home/teamcity/svn_checkout/Galil/Common/OSAL/src/PackageManager.cpp:76
[17:32:01]: Process exited with code 0
[17:32:01]: Publishing internal artifacts
[17:32:01]: [Publishing internal artifacts] Sending build.finish.properties file
[17:32:01]: Build finished

Why Teamcity is green although #failure notification sent ?

Thanks in advance.
Vadim.
7 comments
Comment actions Permalink

Vadim,

please check how build failure conditions are set on General Settings page:
Capture.PNG

Michael

0
Comment actions Permalink

  • build process exit code is not zero
  • at least one test failed
  • an error message is logged by build runner
  • it runs longer than minutes
  • an out of memory or crash is detected (Java only)
Build options: enable hanging builds detection
enable status widget
Limit the number of simultaneously running builds (0 - unlimited)


looks good, any other thoughts ?

Thanks,
Vadim.
0
Comment actions Permalink

Sorry, I don't see whether the checkbox is set or not.

If it has been enabled, then post a full build log please.

Thanks

0
Comment actions Permalink

checkbox checked.
log attached.
thanks,

vadim.



Attachment(s):
Galil_-_Continuous_Integraton_Server_Tests_Run_264.log.zip
0
Comment actions Permalink

Hi Vadim

Could you please additionally post teamcity-build.log file from an buidl agent machine.
I suppose there is something wrong with service messages, but need to check.

Thanks

0
Comment actions Permalink

Found the problem.

Thanks for the help.

0
Comment actions Permalink

Could you share what was the reason?

Thanks

0

Please sign in to leave a comment.