Can anyone help me debug a "pending changes but not triggering build" issue?

I'm trying to work out in what order I should debug a problem we have with TeamCity.

Background:
A little while ago our install of TeamCity crashed with memory error and resulted in a corrupt HSQL database. We then setup an Oracle DB which TC is running against now. Almost everything was brought back including projects, build configs etc.

Ever since then TC has not been triggering builds properly. TC knowns there are pending changes and if I manually hit "Run" the projects will build successfully.

I've checked the teamcity-vcs.log file and it can see the changes that are there:
     VCS plugin vault-vcs reported changes for vault: http://[serverxxx]/VaultService {id=1}; 1 changes collected

But it never triggers a build, whereas it always used to. Can anyone point me to a log file I should look at?

I'm on the verge of uninstalling TeamCity completely and reinstalling it, which means setting up all the projects and build configs all over again - thankfully we've only put 13 in so far!

6 comments
Comment actions Permalink

Hi Phil

How is the build trigger configured, could you post a screenshot please.

Michael

0
Comment actions Permalink

Hi Michael,

The build is triggered via a VCS check-in. It uses default values. Up until we switched to the Oracle DB as the backend for TC it all worked fine.

All of our builds are triggered in exactly the same way and it's one build config per project. All projects used to build fine with no problems at all.

Many thanks for any help you can provide.

Phil



Attachment(s):
tc2.png
tc1.png
0
Comment actions Permalink

I'm seriously considering just scrapping the entire TC install and rebuilding it. I've tried upgrading to the latest version of TC but no change. I've added a scheduled build into the configs and they run okay.

If someone could point me to a log file, or something that is going to tell me at which stage the VCS trigger pushes a request to run the build. All I see in the VCS logs are that it can see a change.

Is it a problem with the Sourcegear Vault VCS trigger? If someone could tell me what I should see in my log files to show a properly triggered build then I can begin to work out where the problem might lie but at the moment I've got a broken CI model and my developers are beginning to lose faith in TC.

0
Comment actions Permalink

Did you ever figure out what was causing this issue?  I am seeing the same thing.  I had a configuration build setup that was detecting VCS changes and initiating a build, i.e. everything was working how I wanted it to.  Then I switched from the Internal TeamCity database to an Oracle Database and now it will detect the changes but will not initiate a build.  It is constantly in the "Pending Changes" tab and never gets pushed to the Build Queue.

Any help would be appreciated.

0
Comment actions Permalink

Alex,

Here is a related thread with some hints: http://devnet.jetbrains.net/message/5446283#5446283 and also a related issue: TW-13114
If you are using TeamCity 6.5 or above we would like to get additional details on the issue.

0
Comment actions Permalink

Yegor,

Thanks for the additional links.  This issue was resolved, although I don't know how.  When I was doing it on Friday I may not have been waiting long enough (it took longer than expected, but eventually pushed to the Build Queue).  I went in to test something different and noticed that it was pushing to the Build Queue like it should be.

~Alex

0

Please sign in to leave a comment.