"Launcher is waiting to be killed by upgrade process" never completes

I've just installed the lastest eap, but can't get seem to get any agent to run or connect. I get the message in the subject and then nothing else  -- every. With the previous eap the agent started right and worked just fine. Is there any way to do a manual upgrade?

4 comments
Comment actions Permalink

I saw some posts that windows anti-virus could block the upgrade, but I am running on linux. The update folder gets populated but is has the same contents as the agent being updated.

0
Comment actions Permalink

Well, I simply ran the command that was shown in the log file and the upgrade ran and completed immediatly. Then the teamcity server saw the agent and life is good. Some glitches with the lastest eap maybe?

0
Comment actions Permalink

Thanks for feedback, Barry

If that happens again, please show us logs from problem agent machine.

Michael

0
Comment actions Permalink

Hello,

Linux update should stop/start agent process to finish.
It's inplemented in the following way:
- agent downloads upgrade patches
- agent starts upgrade process (commandline you found in logs)
- agent hungs to wait till it will be stopped
- upgrade process calls "agent.sh stop force" to kill agent process.
- upgrade replaces all files
- upgrade calls agent.sh start to start agent once more.

According to your report, agent failed to start upgade process to kill itself. Glat to read you worked around the issue. Please note, there are some scenarios that may require agents to autoupgrade.

0

Please sign in to leave a comment.