Trouble setting up cloud integration with EC2

I am having getting the EC2 connectivity setup under TeamCity 7.0.  The TeamCity build server is running outside of EC2.

- The cloud instances that appear say that they are not compatible with the build definitions.  They report that they are missing NAnt / GIT.  The AMI however contains these and I have checked the TC EC2 instances being created to confirm.
- The agent log (EC2 spot instances being setup) show that there is a read time out connecting to http://169.254.169.254/2009-04-04.  I ran this link in a browser and it eventually comes up (although it takes 7-10 seconds).
- Have tried to use the base Windows 2008 / R2 AMI fresh (both small / micro types) and receive the log entries below.
- Turned off Windows firewall and setup the security zone to allow all ports inbound.
- The log timestamps between the previous entry and the EC2 read timeout message is about about 3 seconds.  Is the default timeout 3 seconds?  Should it take that long to return from that URL?  Is there a way to extend it?

The following is in the agent logs around the EC2 checks:

[2012-03-14 01:37:51,734]   INFO - t.AmazonInstanceMetadataReader - Amazon is not available. Amazon EC2 integration is not active: Failed to connect to http://169.254.169.254/2009-04-04. Read timed outRead timed out
[2012-03-14 01:37:51,734]   INFO - .amazon.agent.AmazonProperties - Fetched AmazonEC2 instance metadata:  
[2012-03-14 01:37:51,734]   INFO - zon.agent.AmazonMetadataChecks - Amazon EC instance metadata contains no keys
[2012-03-14 01:37:51,734]   WARN - .amazon.agent.AmazonProperties - Fetched Amazon EC2 instance metadata does not contain required values. Probably this agent was not started inside Amazon EC2. Is proxy server used?


Does anyone have any thoughts on things to try to troubleshoot?  Could this still be a firewall issue?

Thanks.
1 comment
Comment actions Permalink

Hi Sullivan

It looks like the cloud machine has network connectivity issues - auto-assigned IP-address in 169.254.0.0 subnet means it cannot connect to DHCP server and obtain real address. So TeamCity web server cannot call it back.

0

Please sign in to leave a comment.