TC7 slow web UI

Hi,

After upgrading to TeamCity 7.0.2 (from 6.5), we see TC project web pages loading much slower (~30 seconds). Is this a known issue?

We observe the TeamCity tomcat process taking up 50% of the CPU when we opened up the project page in 8 different tabs simultaneously. Not sure if this is normal behaviour.

We would like help to diagnose this problem further with your help please.

Specifically we would like to know where to go to see what TeamCity is doing when the user interacts with the web UI. Ideally, from there we can identify the step that is taking the longest time when loading a page. We have checked the tomcat and TeamCity server logs but cannot see this information. Also please provide steps to switch to the ideal logging level.

Thanks,
Sadegh

5 comments
Comment actions Permalink

Hi Sadegh

Please create a few thread dumps from the overloaded server, and send them to us for review.

Thanks

0
Comment actions Permalink

Hi Michael,

I created the attached thread dump after opening several tabs and observing the process taking 50% CPU while the the pages took some time to come back.
Please have a look.

Thanks,
Sadegh



Attachment(s):
threadDump-2012-05-14_09.41.54.zip
0
Comment actions Permalink

It seems the problem is not caused by upgrade, but rather by using new feature "Show changes from dependencies". Please submit issue in our tracker with this thread dump attached.

0
Comment actions Permalink

I see! Yes, we are using the new feature "Show changes from dependencies".
I will raise a new issue for this. Thanks Pavel.

0

Please sign in to leave a comment.