No Code Coverage Data using IntelliJ IDEA coverage runner in 7.0.2

I do not get any code coverage data when using the Intellij code coverage runner. I am using an Ant runner and tests are running with the Junit task. My include pattern looks like this "com.*" with no exclude pattern. My Junit task is using "fork=yes forkmode=once". I see the following error in my log

[junit] [2012.05.11 11:55:20] (Coverage): Error writing file C:\BuildAgent\temp\buildTmp\idea5703193067776257712coverage\coverage.ic: java.io.FileNotFoundException: C:\BuildAgent\temp\buildTmp\idea5703193067776257712coverage\coverage.ic (The system cannot find the path specified)

Looking at the server, I see that the idea5703193067776257712coverage directory does not exist.

Any help would be appreciated.

Thanks

5 comments
Comment actions Permalink

Hi Jeff

Could you please post a full build log for this run.

Thanks

0
Comment actions Permalink

Attached is my full build log.

Thanks for looking at this.

Jeff



Attachment(s):
Code_Coverage.log.zip
0
Comment actions Permalink

Does anyone have any ideas?

0
Comment actions Permalink

The problem turned out to be a test that was creating a directory in the java.io.tmpdir and then deleting everything in the java.io.tmpdir directory rather than deleting the directory it created. Since the code coverage data is in java.io.tmpdir, it was being deleted by the test.

0
Comment actions Permalink

Thank you for sharing the solution.

0

Please sign in to leave a comment.