TeamCity not finding my agent

I have installed the agent several times and still TeamCity can not find it. I get the message "CannotPingAgentException: Unable to ping agent dotNETDevLW01". It has worked until we upgraded to the latest TeamCity version. I have tried using 'ownAddress' and still nothing. What am i doing wrong? I have never had this much problem. Help please!!

2 comments
Comment actions Permalink

It has found my agent, but now shows me as disconnected. Saying it can't ping my agent. It is allowed through my firewall. Any suggestions?

0
Comment actions Permalink

Hi Elizabeth

TeamCity uses two-way communication between the server and its agents.
So that the build agent has its port opened too. Go to the server machine, open a web browser and navigate to http://<agent-computer>:<agent-port>/
If everything is configured correctly, you should see a response from the agent:

Method GET not implemented (try POST)


If the port is opened but the agent still cannot register, then please post teamcity-server.log and teamcity-agent.log files.
0

Please sign in to leave a comment.