How to deactivate solution-wide analysis for .NET code inspections

Hello

The newly introduced .NET Inspection runner takes an hour to run on our solution (on a fast server with SSD). One thing that probably slows the analysis is the "solution-wide analysis" feature. However, even though the build reads our settings file that has this feature deactivated, the analysis seems to be executed with the feature activated:

[07:55:29]Running Inspections

[07:55:29]Starting:  C:\BuildAgent\plugins\dotnet-tools\bin\inspectcode.exe  /config=D:\TeamCity\buildAgent\temp\agentTmp\dotnet-tools-inspectcode.config

[07:55:29]in directory: D:\TeamCity\buildAgent\work\3557b9939e757a57

[07:55:29]JetBrains InspectCode for .NET

[07:55:29]Running in 64-bit mode, .NET runtime 2.0.50727.4971 under Microsoft Windows NT 6.1.7600.0

[07:55:41]Custom settings layer is mounted. Used file AllProjects.sln.DotSettings

[07:55:50]Solution-wide analysis is enabled

[07:55:50]Opening solution D:\TeamCity\buildAgent\work\3557b9939e757a57\AllProjects.sln

[07:57:27]Collecting inspection scope



Can the solution-wide analysis be deactivated?


Marcel
1 comment
Comment actions Permalink

Marcel,
It is possible by specifing configuration parameter 'teamcity.dotNetTools.inspecitons.disableSolutionWideAnalysis' = true
But still it is a bug that TeamCity does not rely on the setting from R#'s profile. I've created issue for that.
Please let me know if it is work for you.
Also we've made an improvement that should reflect analysis's performance. Now .NET inspections runner uses caches, produced by previous builds on the same agent. This fix is already avaliable in 7.1 EAP.

0

Please sign in to leave a comment.