Build agent unable to find PowerShell

Hi *,

I have TC's build agent installed on Windows 2008 R2 SP1 Core. The server has PowerShell 2.0 installed (double checked, and actually from PS downloaded the TC installation). Looking at some build configuration I see these being incompatible with this agent, because powershell_x86/powershell_x64 is required. I tried deleting build agents dirs to force upgrade, but no luck. Interestingly if I provide powershell_x86, powershell_x86_Path (and for 64bit) variables into config file manually, everything runs fine.

Is there anything I can do to have the build agent find PowerShell automatically? What/where is it looking for it? Maybe the 'Core' is problem.

Thanks JC

3 comments
Comment actions Permalink

Please provide agent debug logs containing start of build agent,
as shown in Reporting Issues - TeamCity 7.x Documentation - Confluence

0
Comment actions Permalink

Hello,

Thank you for info. It is still not clear for me how to fix it.
I checked the registry on Server 2008R2 SP1 and found no issue.


Please attach the dump of registry of HKLM/Software/Microsoft/PowerShell and  HKLM/WOW6423Node/Software/Microsoft/PowerShell

0

Please sign in to leave a comment.