Build not getting triggered when VCS Checkout rules are defined

I am having problem with build triggering when Checkout Rules are defined in TeamCity.

Below are the Environment Details:

- TeamCity v6.0.3

- IBM RTC v3.0.1 repository

- JDK v 1.6

I have created a build configuration, which has no checkout rules defined. When I deliver changes to the Stream, build is automatically triggered, that because of the "VCS Trigger" that is defined for the build configuration.

When, I define the Checkout rules (only Include Rules) and modify the code specific to the directories that match the Checkout Rules, Build is not getting triggered, eventhough the VCS Trigger is defined.

I have tried the same approach with the TeamCity v7.0.0 server as well with the same result. Builds are getting triggered only if the Checkout rules are not defined.

We have defined a TeamCity-RTC plug-in to enhance TeamCity support for RTC repository as well.

When changes are delivered, collectChanges() method is picking up the changes, but, then, build is not getting triggered in TeamCity as Changes are ignored.

Below is the lines of trace, I have observed in teamcity-vcs.log file:

Collecting changes using rtc from version: snapshot name  to version: null using rules: tool_test_component/web=>tool_test_component/web
[2012-07-16 12:17:00,598]  ERROR [5 {id=8} {id=8}] -      jetbrains.buildServer.VCS - No. of changes for the VCS Root--->tool_test_unstable are-->0
[2012-07-16 12:17:00,598]  ERROR [5 {id=8} {id=8}] -      jetbrains.buildServer.VCS - No changes detected
[2012-07-16 12:17:00,598]  ERROR [5 {id=8} {id=8}] -      jetbrains.buildServer.VCS - Done collecting changes for rtc : RTC-1://usilap570b-dev/Tool-test/tool_test_unstable => 0
[2012-07-16 12:17:32,839]  ERROR [3 {id=9} {id=9}] -      jetbrains.buildServer.VCS - Collecting changes using rtc from version: Mon Jul 16 2012 12:10:30.330 to version: null using rules: =>
[2012-07-16 12:17:36,398]  ERROR [3 {id=9} {id=9}] -      jetbrains.buildServer.VCS - No. of changes for the VCS Root--->tools_test_trunk_unstable_flowed are-->0
[2012-07-16 12:17:36,398]  ERROR [3 {id=9} {id=9}] -      jetbrains.buildServer.VCS - No changes detected

Please suggest me on how to handle this error.

In the collectChanges() method which is overriden, I could see the changes are picked up and changesets are identified by the build process. But the changes are not picked up by the build configuration and build is not triggered.

This works perfectly fine, if there are no checkoout rules defined. Even if I use the Shared VCS Root or not.

Please sign in to leave a comment.