How to exclude .form files?

Hi, I have an IDEA project where one of the JPanels is designed using netbeans. This means there is a .java and a .form file. IDEA needs to ignore the .form file as it is in netbeans format ... that's simple to do - I just say to exclude it in the compiler settings of the project. This results in the following entry in the compiler.xml file in the .idea directory:

<excludeFromCompile>       <file url="file://$PROJECT_DIR$/../gui/src/com/ccm/research/gp/gui/panels/ConfigPanel.form" />     </excludeFromCompile>



This all compiles fine in the IDE now, but in Team City, I still get an error concerning the form file. The build log has the following in it:

jb_instrumentations
[22:44:39]Added @NotNull assertions to 0 files
[22:44:39][jb_instrumentations] Cannot process form file /mnt/md0/home/teamcity/buildAgent/work/191cb7004252bee5/research/gp/trunk/gui/src/com/ccm/research/gp/gui/panels/ConfigPanel.form. Reason: com.intellij.uiDesigner.compiler.UnexpectedFormElementException: unexpected element: [Element: <Form/>]
[22:44:39]Total 3 chunks for TEST_COMPILE detected


I am using the Intellij IDEA code coverage setting and have added the following to the patterns to exclude from instrumentation:

.*ConfigPanel

Does anyone know what I am missing here? It seems that TC is not picking up the compile.xml file from the IDEA project properly.

Ian

Please sign in to leave a comment.