ClearCase error after removing load rule from VCS Root

We’re using TeamCity Enterprise 7.1 EAP (build 23732) and ClearCase for VCS (Agent side checkout.)  When I change the config spec of a VCS Root, my build agents start getting errors (see below.)  It appears that the Agent view is trying to update, but cannot because I have removed a load rule.  This is OK; I want to remove the load rule from the Agent view…unfortunately, I don’t know how.

I have tried:

    - Remove all ClearCase views from the Agent

    - Uninstall/delete/Reinstall the build agent

    - Reboot the server and agent

But I still get the errors.  Where is TeamCity storing this stale view information?  On the server?   How can I force the agent to update the ClearCase view (thus removing the load rule?)

Thanks,

Bryan

Error details:

 

Failed to start build #72

Description: http://hodag/img/buildStates/error.gifUncategorized build problems

Description: http://hodag/img/buildStates/error.gif

Updating from   ClearCase repository failed.

Description: http://hodag/img/buildStates/error.gif

Failed to perform   checkout on agent: jetbrains.buildServer.vcs.clearcase.CCException:   java.io.IOException: cleartool: Warning: 1 objects were eliminated from the   new config spec's load rules: Continue, and unload these objects? [no]   cleartool: Error: Unable to change configuration specification: error   detected by ClearCase subsystem.: command: {"cleartool setcs   "C:\BuildAgent\temp\globalTmp\config_spec_5500323287230271818""   in: "C:\BuildAgent\work\dc9058bcb6c65cfd"}

Build errors

[16:34:53]Updating sources: agent side checkout (1s)

[16:34:53][Updating sources] VCS Root: clearcase: \\server\views\main\src (1s)

[16:34:53][VCS Root: clearcase: \\server\views\main\src] Updating from ClearCase repository... (1s)

[16:34:54][Updating from ClearCase repository...] Updating from ClearCase repository failed.

[16:34:54][Updating sources] Failed to perform checkout on agent: jetbrains.buildServer.vcs.clearcase.CCException: java.io.IOException: cleartool: Warning: 1 objects were eliminated from the new config spec's load rules:

Continue, and unload these objects? [no] cleartool: Error: Unable to change configuration specification: error detected by ClearCase subsystem.: command: {"cleartool setcs "C:\BuildAgent\temp\globalTmp\config_spec_5500323287230271818"" in: "C:\BuildAgent\work\dc9058bcb6c65cfd"}

3 comments
Comment actions Permalink

Update:   Changing the VCS checkout mode from 'Automatically on agent' to 'Automatically on server' allows the build to run without ClearCase errors; unfortunately, the build now takes 41 minutes instead of 17.  

Does anyone know why server checkout is so much slower than agent checkout for ClearCase?

I still don't understand which ClearCase view the original error message is originating from.  

-Bryan

0
Comment actions Permalink

Hi,

Sorry for the delay in replying.
For creating a view on an agent TeamCity uses config spec from the VCS root's server view. Config spec is just copied with adding of time rule, so load rules are absolutely the same as on the server view.
Server checkout is slower because on an agent TeamCity just calls "cleartool update" command and it is fast, while on the server-side TeamCity calls "cleartool lshistory" and parses its output, and it is not so fast as "cleartool update".

0
Comment actions Permalink

Hi Maxim,

Thanks for the response.  It looks like the Agent is trying to use the same config spec as the VCS root server's view, but if I removed a load rule from the VCS root config spec, the Agent is unable to update its view.  It correctly recognizes that load rules were removed, but ClearCase prompts for confirmation.  TeamCity does not allow me to confirm removal of the load rules, and it fails immediately.

I created Issue TW-22691 for this:  http://youtrack.jetbrains.com/issue/TW-22691

It seems like providing an option to add the -force parameter to cleartool setcs would fix the problem.

-Bryan

0

Please sign in to leave a comment.