Error starting teamcity 7.04 after restoring database

After doing a restore, starting the service, and accessing the teamcity website, I get the following page with error:

TeamCity Server Startup Error

An error was encountered during TeamCity server startup


TeamCity data needs upgrade, but upgrade is not possible:  configuration with old data format exists but database does not exist or  is not accessible.
Upgrade cannot proceed as TeamCity can upgrade the data directory and  database only at the same time. If you want to proceed with partial data  please run the previous TeamCity version (matching the data version)  first.





I have tried to understand what it is saying, but I am missing the mark.  There must be something fundamentally wrong with my order of operations when building this server.  I've read several of the install documents, etc.  I'm missing something.


This is a "new" server that I am building out with the latest version of Teamcity (7.04).  I am trying to restore a backup to it that I just made from the webgui on our production 6.5x Teamcity server.
In general, here are the steps that got me to this point:


Kickstarted a new CentOS 5.5 server.
Installed our standard packages


Installed MySQL 64-bit
Installed 32-bit library support (yum install glibc.i686)
Installed 32-bit java (Version 6 Update 33)
Created teamcity user within CentOS
Unpack teamcity 7.04
Log off and then log back on as teamcity user
Started the teamcity service with: /home/teamcity/TeamCity/bin/teamcity-server.sh start
From a web browser I went to: http://teamcity2.allwebleads.com:8111/
I let it proceed through maintenance mode.
Install MySQL Connector in /home/teamcity/.BuildServer/lib/jdbc

Inside /home/teamcity/.BuildServer/config I ran the command: cp database.mysql.properties.dist database.properties
I modified database.properties to the values I needed and then copied it to /tmp
Stopped the teamcity service with: /home/teamcity/TeamCity/bin//teamcity-server.sh stop
Deleted all files and folders inside /home/teamcity/.BuildServer/config  (rm -rf *)
Deleted all files and folders inside /home/teamcity/.BuildServer/system  (rm -rf *)
Configured MySQL database by creating the teamcity database, creating the teamcity user within MySQL and granting the teamcity user with MySQL all privileges to the teamcity database.
Used rsync to copy the .zip backup file created from the webgui on the production server to this new server [teamcity2] in /home/teamcity/.BuildServer/backup
Ran the following command to create/restore the database:

/home/teamcity/TeamCity/bin/maintainDB.sh restore -F  /home/teamcity/.BuildServer/backup/TeamCity_Backup_20120701_230000.zip -A  /home/teamcity/.BuildServer -T /tmp/database.properties

My next step was to copy over the archive folder from the production server to the new server, but before doing that I started the service and then opened the web page to the error I mentioned above.

I'm not sure if I'm supposed to "migrate" from the builtin database to MySQL somewhere before the restore or something like that?  Please, I would greatly appreciate some help.









1 comment
Comment actions Permalink

Please disregard.  I made a very basic mistake.

After performing the restore, I forgot that I needed to copy the database.properties file from the /tmp folder to /home/teamcity/.BuildServer/config/database.properties

Doing so resolved the problem.

0

Please sign in to leave a comment.