Trouble Setting Up TeamCity 7.1 on Windows 2008

I have been having a frustrating time trying to get TeamCity 7.1 (build 23907) working with SQL Server 2008 R2. I have followed the instructions from http://confluence.jetbrains.net/display/TCD7/Setting+up+an+External+Database to the letter and then even tried changing the order of some of the steps but no matter what I do, there is no indication that the configuration settings are being detected by TeamCity. I tried both of the available drivers, and even resorted to changing both the Windows user account that TeamCity runs under to administrator as well as changing the database login to sa with no avail.

I suspect that the issue has something to do with the fact that the initial setup phase hangs and never completes. It usually stops at the "Initializing TeamCity server components" step. I have let it run for as long as 8 hours, but there doesn't appear to be any additional logging activity in the teamcity-server log file after it reaches the following steps:

[2012-08-17 01:30:33,749]   INFO -   jetbrains.buildServer.SERVER - Agent has been registered: BuildServer {id=1, host=127.0.0.1:9090, agentTypeId=1, pool=Default}, not running a build
[2012-08-17 01:39:47,327]   INFO -   jetbrains.buildServer.SERVER - Start loading test runs for investigations and mutes into cache...
[2012-08-17 01:39:47,327]   INFO -   jetbrains.buildServer.SERVER - Done loading test runs

Anyway, I have been able to get into the dashboard by reloading the page and then everything appears to work fine (at first). After the refresh it asks me to agree to the license, create an account, and then it displays the "Create a project" page. However, when I click the administration link, it displays a message "The server currently uses the internal storage engine.    For production purposes it is highly recommended to use a standalone database which provides better stability as the storage engine." I confirmed that the SQL Server TeamCity database has no tables in it despite the driver and configuration settings in place as described in the documentation.

Then I am back to sqare 1. I have repeated the delete and recreate data direcotory process at least 10 times with no success. So what am I missing here?

Configuration:

Windows Server 2008 R2
2 GB RAM
Virtual Box Virtualized Server (Running on Windows 7 Home Premium Guest OS)
SQL Server 2008 R2 (Mixed Mode Authentication)

TeamCity (both Agent and Server) is running under a local windows user account (currently in the Administrators role)
User/password authentication for SQL Server (currently the sa account)

The only default TeamCity settings I changed were the port to 8080 and the TeamCity Data Directory to F:\ProgramData\JetBrains\TeamCity

1 comment
Comment actions Permalink

Well, after more tinkering I finally figured out what was going on.

The issue of the data directory creation was due to the fact that the redirect method used is apparently not compatible with IE9. I used Firefox and the setup completed as expected.

The issue with the SQL Server configuration was due to the fact that by default Windows hides the extension. I had completely overlooked this because I normally run Windows with this feature turned off. As a result, the configuration file was misnamed "database.properties.txt". Although this was entirely my fault, it would have helped to have a reminder in the documentation to turn off the "hide extensions of known file types" feature in Windows so it wouldn't have been overlooked.

It would also help if the following were defined in the documentation because it was not very clear what to do:

  1. "Shutdown the TeamCity server". How? It would have been better to say something like stop the Windows service.
  2. "Run TeamCity with the default settings". How? It would have been helpful to tell the user to open the TeamCity URL in a browser.


I chose to use TeamCity primarily because it is considered easier to configure than the alternatives. However, thus far this turned out to be a misnomer because of unclear documentation.

0

Please sign in to leave a comment.