No VCS updates after artifact dependencies cleanDestination marked with 'true'

I ran into a problem where a build configruation started failing due to the files in the VCS's not being in the build agent work directory.  I have spent hours debugging this and tried the following:

  1. 'clean sources on this agent'  http://confluence.jetbrains.net/display/TCD7/Clean+Checkout
  2. Removing the 'system\caches' folder on the server
  3. restarted the server
  4. 'Copy' the build configuration
  5. Add a second, benign VCS
  6. rebooted the build agent
  7. recreate the build configuration and incrementaly find where it fails


Item #7 yielded a helpful result where once I marked the artificat dependency with 'clean destination paths before downloading artifacts' the VCS source files were no longer in the work directory.  Unchecking this setting does not resolve the problem.
[Update] Turns out the debug stated here was not conclusive; in some cases it was working on a different build agent.   Either way, since the VCS is SVN the workaround was to update the 'VCS checkout mode' to 'automatically on agent'

At this point I need to manually create a build configuration and use that, as the others seem to be corrupt in some way.  

Any idea to what is going on?

Please sign in to leave a comment.