TFS: How to force TeamCity to create workspaces

I removed all workspaces on my build server. Don't ask why. I had to. Now I want TeamCity to create his workspaces (by one for each build). I run a build and it succeed. So TC managed to get latest version of sources (I have 'clean all files before build' option for my builds). But command "tf.exe workspaces" doesn't show any new workspaces. So do VS's Source Explorer (workspaces dialog doesn't contain TC's workspaces as before). It's very bad for me because I need workspaces for symbols indexing (PDBs) to work. But 'tf workfold' (run in builds' directories) can't find any mapped folders.

So my question is: when TC does actualy create TFS workspaces and to force it to recreate them again?

p.s. I tried to remove all data in "C:\Users\{User}\AppData\Local\Microsoft\Team Foundation\", reboot agent.

UPDATE:
Well, it seems that TC creates workspaces somehow. I have two builds: CI and CI_Deploy. CI_Deploy depends (triggers) on CI. After they both finish I can see a new workspace. But this workspace is for the second build. And there is no a workspace for the first one. I check this by investigated workspaces in VS's 'Manage Workspaces' dialog.

1 comment
Comment actions Permalink

The different behaviors are due to 'VCS checkout mode' option (on agent or on server). After I chose 'automaticaly on agent' TC creates workspaces.

0

Please sign in to leave a comment.