Free disk space build feature not working?


I have an agent that is installed on an NFS drive but is configured to have its system, temp and work directories on local disk. All our build configurations are setup with the 'free disk space' build feature set at 1G. However, currently the local disk is full and builds are still being scheduled to run on that agent, which then immediately fail.

I was under the impression that if there wasn't enough space with this build feature then TC would try and delete stuff. At the time there was loads of stuff that the agent could have deleted:

bash-3.00$ du -ks *
5924836         system
208             temp
10651892        work

This is on TeamCity version 6.5.4. Am I missing something?

Many thanks

Comment actions Permalink

I am encountering the same problem with version 7.0.3. No matter how I set the property, whether we have the minimum disk space feature enabled or not. We have the minimum set to 4GB, yet the build still attempts to kick off without having cleared any space, and it consequently fails.

Comment actions Permalink

Update: what seems to be critically important is to set up the home directory of the TeamCity user so that .BuildServer, buildAgent and additional build agent folders are inside it.

We had created the TeamCity user like any other user (except with no login) with its home directory under /home, while we wanted all the builds to go on under a separate volume, /work. So we created a folder /work/TeamCity and proceeded to configure TeamCity to put the binaries, .BuildServer and buildAgent folders under this. It all worked fine, but I suspect that the disk space thresholds were still being applied to /home/teamcity, which didn't contain anything of value.

Consequently none of the old builds were being wiped, no matter what configuration values we set up.

As soon as I altered the home of the TeamCity user to /work/TeamCity, and moved all the usual home files across, all the folders under buildAgent/work/.old got deleted at the very next build.


Please sign in to leave a comment.