Problems connecting TeamCity 7.1.3 to SQL Server

Hello TeamCity friends,

Our company is trying out TeamCity for CI builds and have installed version 7.1.3 on a Server 2008 R2 machine. So far we've been able to create, configure and build projects using TC and local database, but now we want to connect TC to a SQL db going forward. We've followed the instructions here but have had no luck so far connecting TC to our SQL Server 2008 R2:  http://confluence.jetbrains.com/display/TCD7/Setting+up+an+External+Database#SettingupanExternalDatabase-MicrosoftSQLServer

Here are my connection settings when using the JTDS driver:

connectionUrl=jdbc:jtds:sqlserver://teamcitysqlserver:1433/TeamCityDb
connectionProperties.user=DOMAIN/user
connectionProperties.password=UniquePassword
connectionProperties.instance=MSSQL



And here are my connection settings when using the native JDBC driver:

connectionUrl=jdbc:sqlserver://teamcitysqlserver:1433;databaseName=TeamCityDb
connectionProperties.user=DOMAIN/user
connectionProperties.password=UniquePassword



However, I keep getting the same error when trying to connect:   SQL query: connect SQL exception: Login failed for user

Both the SQL server and TeamCity server are on the same domain; and the DOMAIN/user account we're using to connect to SQL is the accout we're using to run the TeamCity service and is also the SQL admin & dbo. Also, I have SQL configured with mixed authentication mode (both Windows and SQL authentication)

Is there something wrong with my database.properties file settings?  What could be the issue?

Thanks,
Keith
2 comments

Hello Keith,

I've got two suggestions in this case, try one of:

1. Try to remove the DOMAIN/ from the connection properties

2. Try to use integrated secirity

Best regards!

0

Hi Leonid,

Thanks for the tips. I tried removing DOMAIN/ and still received the same error. Also tried integrated security with the MS native JDBC driver and got an error message saying that the driver does not support integrated security. D'oh!  And so I tried integrated security with the JTDS driver and received a different error about the database being empty or missing. At this point it would have been great for TeamCity to provide additional documentation as to what to do when this type of message is displayed. After much research I discovered that I needed to login as admin using the secure token, and low and behold, there's another step to build the database. Wow! That would have been nice to know if advance. But anyway, I have things working nicely now and am connected to our SQL db.

Regards,
Keith

0

Please sign in to leave a comment.