Git submodules update is stuck

I use TeamCity version 7.1.4
I am trying to setup a project that builds a git repository that contains submodules.
The repositories are all private and located in bitbucket.
The fetch URL is something like: https://bitbucket.org/MY_ACCOUNT/MY_PROJECT.git
Authentication method is "Password" where I provide a username and password.
When I test the connection it works.
When I run the configuration I can see that the files in the repository are succesfully cloned in a folder like
C:\BuildAgent\work\2eb7upe16463b84a
However, when the agent tries to get the repositories is stuck in the first repository.
It was running for many hours without success and the repository is small.
Looking at the teamcity-vcs.log I see

[2013-03-15 10:48:21,170]   INFO -      jetbrains.buildServer.VCS - [C:\BuildAgent\work\2eb7upe16463b84a]: "C:\Program Files (x86)\Git\bin\git.exe" log -n1 --pretty=format:%H%x20%s fc0cf57e1cbd06145d846b58b69ed8355f7f17cd --
[2013-03-15 10:48:21,206]   INFO -      jetbrains.buildServer.VCS - [C:\BuildAgent\work\2eb7upe16463b84a]: "C:\Program Files (x86)\Git\bin\git.exe" branch
[2013-03-15 10:48:21,260]   INFO -      jetbrains.buildServer.VCS - [C:\BuildAgent\work\2eb7upe16463b84a]: "C:\Program Files (x86)\Git\bin\git.exe" branch -l --track master refs/remotes/origin/master
[2013-03-15 10:48:21,312]   INFO -      jetbrains.buildServer.VCS - [C:\BuildAgent\work\2eb7upe16463b84a]: "C:\Program Files (x86)\Git\bin\git.exe" update-ref -m "setting revision to checkout" refs/heads/master fc0cf57e1cbd06145d846b58b69ed8355f7f17cd
[2013-03-15 10:48:21,343]   INFO -      jetbrains.buildServer.VCS - [C:\BuildAgent\work\2eb7upe16463b84a]: "C:\Program Files (x86)\Git\bin\git.exe" checkout -q -f master
[2013-03-15 10:48:21,703]   INFO -      jetbrains.buildServer.VCS - [C:\BuildAgent\work\2eb7upe16463b84a]: "C:\Program Files (x86)\Git\bin\git.exe" clean -f -d -x
[2013-03-15 10:48:21,758]   INFO -      jetbrains.buildServer.VCS - [C:\BuildAgent\work\2eb7upe16463b84a]: "C:\Program Files (x86)\Git\bin\git.exe" submodule init
[2013-03-15 10:48:34,063]   INFO -      jetbrains.buildServer.VCS - [C:\BuildAgent\work\2eb7upe16463b84a]: "C:\Program Files (x86)\Git\bin\git.exe" -c core.askpass=C:\BuildAgent\temp\globalTmp\pass8734605955689611158.bat submodule update



These are the last lines in the log.
There is a .git file generated in the first submodule folder, but no files.
My .gitmodules files has the following entries

[submodule "3rdParty/LIB_1"]
 path = 3rdParty/LIB_1
 url = https://bitbucket.org/MY_ACCOUNT/lib1.git
[submodule "3rdParty/LIB_2"]
 path = 3rdParty/LIB_2
 url = https://bitbucket.org/MY_ACCOUNT/lib2.git

2 comments
Comment actions Permalink

Hi,

usually such problems arise when submodule requires a different authentication than the main repository, but since your submodules are in the same bitbucket account this is not the case. If you run 'git submodule update' inside C:\BuildAgent\work\2eb7upe16463b84a manually, does it succeed?

0
Comment actions Permalink

When I manually updated it succeeded.
Anyway, I ended up using Default private key with SSH which worked like a charm.
It would be better though if it supported passphrase.

0

Please sign in to leave a comment.