How to change the build timeout from 30 minutes?

I have a few long builds that shouldn't time out after 30 minutes. But I don't see any way to change this setting in TeamCity. How can this be done?

Please sign in to leave a comment.