Teamcity as a NuGet server - package does not show up in feed

It's not completely clear to me if I have to

1. enable Publish created packages to build artifacts at the pack build step
2. and/or copy it as an artifact in the general settings

Reading the documentation it seems that step 1. is enough (extract below) but it didn't show up in the feed. So I also dit 2. but alas

Can someone point me in the right direction?

Tom

"In the "Output Directory" field, specify the path where generated NuGet package should be put. Optionally, you can clean this directory before packing. If you're using TeamCity as NuGet repository, select the Publish created packages to build artifacts check box to publish packages to TeamCity's NuGet server and be able to use them as regular TeamCity artifacts."

1 comment
Comment actions Permalink

fixed, Problem was between the user and keyboard

I was staring at the url that teamcity gives when you enable the nuget server. It was empty so my (logical?) conclusion was that it did not work

If you past it into VS however it works.

I read on the forum simialer problems that users reported so maybe its a good idea to put some text in the UI of give a url that returns sometinhg

0

Please sign in to leave a comment.